Latest News

Follow the latest news on OpenShot Video Editor!


,

After many long nights, and many frustrating days of work, I am proud to announce a set of 25 Debian Installers, spread out across 6 Ubuntu distributions! Why 25 installers you ask? Well, let me break it down for everyone:

OpenShot is just a Python program, so we just need 1 installer for that. Check.
x264, Frie0r, FFmpeg, and MLT. That's 4 more. Check.

Now, since these "dependency" packages are not Python, we need to be sure and build these 4 packages against the following versions of Ubuntu:

  • 32 Bit - Ubuntu 8.04
  • 32 Bit - Ubuntu 8.10
  • 32 Bit - Ubuntu 9.04
    -------------------------
  • 64 Bit - Ubuntu 8.04
  • 64 Bit - Ubuntu 8.10
  • 64 Bit - Ubuntu 9.04
So, that's 6 distributions X 4 packages = 24 deb installers. + 1 OpenShot installer, so that equals 25 deb installers.

I have created an archive for each set of dependencies, and added them to the official download page. After you get everything installed, you will only need to update the main OpenShot.deb file as I release new versions. In other words, you only have to install the dependencies one time. Also, just to be clear, OpenShot is still very much in development, and is changing rapidly. This is not an official release... just an easier-to-install developer snapshot.

Soon I will be adding the completed language translations to the download page as well. These will be .deb installers as well. Please be patient with the translations, as it might take a few days to get these setup and uploaded. =)

I'm going to come right out and say it. I am not an expert Debian package creator, and I'm sure there are better ways to create these .deb files. If you happen to be an expert in this area, please join our LaunchPad team and help us improve our packaging. =) Thanks.

Enjoy the .DEB files everyone!

Share to Facebook Share to Twitter Share to MySpace Stumble It Share to Reddit Share to Delicious More...

66 comments

Subscribe to: Post Comments (Atom)